This issue has been resolved. Our apologies for the inconvenience.
Posted Jan 20, 2026 - 15:47 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 20, 2026 - 09:20 CET
Identified
Currently you cannot complete your Peppol registration when the company you are trying to register is already subscribed to Peppol in Exact Online. During the onboarding process you receive a selection of multiple accounts, but selecting an account results in an 'access denied' error. We have identified the issue and are working on a fix. Our apologies for the inconvenience.