Exact Online Fiscal and Annual Reporting - Scheduled Maintenance on 19th of October (NL)

Incident Report for Exact System

Resolved

The scheduled maintenance has been completed.
Posted Oct 21, 2024 - 09:10 CEST

Investigating

You may experience reduced performance on October 19th between 21:00 CEST and 00:00 CEST due to scheduled maintenance. Our apologies for the inconvenience.
Posted Oct 18, 2024 - 15:28 CEST
This incident affected: Exact Online Fiscaal and Exact Online Jaarrekening.