Exact Status Page

Exact Online - Support not reachable through phone (BE)

Incident Report for Exact System

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2026 - 15:49 CET

Investigating

Currently we are facing technical issues with the Exact Support phone lines in Belgium. As a result, you are not able to call Support at this moment. Please use the Exact AI Assistant or contact support via chat or via a web question. Our apologies for the inconvenience
Posted Mar 11, 2026 - 12:25 CET
This incident affects: Customer Support Department.