Exact Status Page

Exact Winbooks - Winbooks on web currently unavailable (BE)

Incident Report for Exact System

Resolved

This issue has been resolved. Our apologies for the inconvenience.
Posted Feb 25, 2026 - 11:17 CET

Investigating

You are currently unable to log in to Winbooks and you will receive a blank page when navigating to https://www.winbooksonweb.be. We are investigating the issue and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Feb 25, 2026 - 09:07 CET
This incident affected: Exact Winbooks.