Exact Status Page

Exact Cloud Services - Elvy application cannot be started on hosted desktop (Global)

Incident Report for Exact System

Monitoring

A fix has been implemented and we are currently monitoring. Please fully log out of the hosted desktop and login again. After this the application should be available again.
Posted Mar 24, 2026 - 12:39 CET

Investigating

At this moment you may experience an issue on the ECS hosted desktop where the Elvy application cannot be found. We are investigating the issue. Our apologies for the inconvenience.
Posted Mar 24, 2026 - 11:44 CET
This incident affects: Exact Cloud Services.