This issue has been resolved. Our apologies for the inconvenience.
Posted Nov 27, 2025 - 12:18 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 27, 2025 - 11:45 CET
Investigating
You may experience an '503 Service Temporarily Unavailable' error when opening an Audit plan. We are investigating the issue. As soon as more information is available we will update this page. Our apologies for the inconvenience.
Posted Nov 27, 2025 - 11:24 CET
This incident affected: Exact Online Jaarrekening.