Exact Online Fiscaal - arrow for next page returns the screen to the page personal data (NL)

Incident Report for Exact System

Resolved

The issue has been resolved. Our apologies for the inconvenience.
Posted May 28, 2025 - 09:07 CEST

Update

This issue is identified and we are working on a fix. Navigation in the left menu can be used as workaround. We will update this page as soon as more information is available. Our apologies for the inconvenience.

Navigation in the left menu works as usual.
Posted May 26, 2025 - 12:44 CEST

Identified

When you click on the button for the next page you will be returned to the page with personal data. We have identified the issue and found that the problem was caused by the latest update of chrome. We will update this page as soon as there is more information available. Our apologies for the inconvenience.
Posted May 23, 2025 - 12:22 CEST
This incident affected: Exact Online Fiscaal.