Exact Proquro - Invoices that go to the inbox are not received.
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 16:24 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 20, 2024 - 13:19 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 19, 2024 - 15:47 CET
Investigating
At the moment, invoices that go to ProQuro via the inbox are not received. We are aware of this and are trying to resolve this as quickly as possible. Our apologies for the inconvenience
Posted Nov 18, 2024 - 15:25 CET
This incident affected: Exact Proquro.