All products - Unable to use Exact PSD2 for Rabobank bank link to receive transactions or send payments (NL)

Incident Report for Exact System

Resolved

The issue has been resolved. Our apologies for the inconvenience.
Posted Sep 23, 2025 - 15:55 CEST

Monitoring

Rabobank has implemented a fix and we are monitoring the results.
Posted Sep 23, 2025 - 12:32 CEST

Identified

You are unable to use your Exact PSD2 for Rabobank bank link to receive transactions or send payments. Rabobank has identified the issue and is working on a solution. We will update this page as soon as new information becomes available. Our apologies for the inconvenience.
Posted Sep 23, 2025 - 11:07 CEST
This incident affected: Bank links / PSD2.