This issue has been resolved by the Rabobank. Our apologies for the inconvenience.
Posted Jul 10, 2025 - 08:33 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 10, 2025 - 08:18 CEST
Investigating
Currently it is not possible to use your Exact PSD2 for Rabobank bank link to receive transactions or send payments. Rabobank has identified the issue and is working on a solution. We will update this page as soon as new information becomes available. Our apologies for the inconvenience.