Exact Online Fiscaal - Incorrectly receiving payment reminders for VAT returns (NL)

Incident Report for Exact System

Resolved

The issue has been resolved. The reminder emails can be considered as not sent if the payment has been debited from the bank account. The incorrect "payment failed" status in the customer portal cannot be changed because it is not possible to check whether this status is correct or not. Our apologies for the inconvenience.
Posted Nov 05, 2025 - 17:07 CET

Investigating

You may have incorrectly received an email with a payment reminder for VAT returns at the end of October. The customer portal shows that the payment failed, but the amount has been debited from the bank account. The payment link in the reminder email also no longer works if the payment has already been made. Please make sure you check whether the amount has actually been debited from your bank account. We are investigating the issue and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Nov 05, 2025 - 09:50 CET
This incident affected: Exact Online Fiscaal.