Exact Online - Performance issues through various menu paths (UK)

Incident Report for Exact System

Resolved

The issue has been resolved. Exact Online performance is back to normal. Our apologies for the inconvenience.
Posted Oct 23, 2024 - 15:41 CEST

Investigating

You might experience performance issues in Exact Online UK environment through various menu paths. We are investigating the issue. Our apologies for the inconvenience.
Posted Oct 23, 2024 - 12:29 CEST
This incident affected: Exact Online.