Exact Status Page

Multivers on premise – Registrations for PEPPOL cannot be completed (BE)

Incident Report for Exact System

Resolved

The issues have been resolved and registering for PEPPOL is possible again. Our apologies for the inconvenience.
Posted Dec 08, 2025 - 16:25 CET

Identified

We are currently not able to complete your Peppol registration. When trying to register for PEPPOL in a Belgian administration, you will see the following error message “Subscription data for RowKey: (number) not found.” We have identified the issue and are working on a fix. Our apologies for the inconvenience.
Posted Nov 18, 2025 - 14:47 CET
This incident affected: Exact Multivers.