Exact Online - Not possible to verify the Peppol registration without an ItsMe account (BE)

Incident Report for Exact System

Resolved

The issue has been resolved and you are now able to verify the Peppol registration without using ItsMe. Our apologies for the inconvenience.
Posted Nov 05, 2025 - 09:47 CET

Monitoring

We have implemented a fix and we are monitoring the results.
Posted Nov 05, 2025 - 08:55 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 22, 2025 - 09:10 CEST

Investigating

It is currently not possible to verify the Peppol registration when you do not have an ItsMe account. We will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Oct 08, 2025 - 09:43 CEST
This incident affected: Exact Online.