Exact Online Fiscaal - The green arrow in a declaration skips a chapter (NL)

Incident Report for Exact System

Resolved

This issue has been resolved. Our apologies for the inconvenience.
Posted Jul 08, 2025 - 09:06 CEST

Investigating

Green arrow on returns always skips a chapter APP2

If you are working on a tax return, the system may skip a chapter if you click on the green arrow. We are investigating this issue and we will update this page as soon as there is more information available. Our apologies for the inconvenience.
Posted Jul 07, 2025 - 10:30 CEST
This incident affected: Exact Online Fiscaal.