We have implemented a fix and are monitoring the results.
Posted Aug 13, 2026 - 16:47 CEST
Identified
The issue has been identified, and a fix is being implemented.
Posted Aug 07, 2026 - 13:18 CEST
Investigating
You may experience that documents successfully deposited with the Chamber of Commerce are not being archived in Hyarchis when having a link between Exact Online Jaarrekening and Hyarchis. We are investigating this issue, and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.