Knab bank statements delayed
Incident Report for Exact System
Resolved
Knab delivered the bank statements this afternoon. The bank statements are available in your company. Our apologies for the inconvenience caused.
Posted Dec 02, 2021 - 16:17 CET
Investigating
The statements from Knab are not delivered yet. They are working hard to solve this. Our apologies for any inconvenience caused.
Posted Dec 02, 2021 - 08:01 CET
This incident affected: Exact Online - Netherlands (Boekhouden, Uren & Facturen, Project Management, Handel, Productie, Accountancy, Mijn[Kantoor]).