Exact Status Page

Exact Multivers Online - Slowness while working in Multivers Online (NL)

Incident Report for Exact System

Update

We are continuing to investigate this issue.
Posted Apr 01, 2026 - 06:59 CEST

Investigating

You may experience slowness when working in Multivers Online. We are investigating this issue. Our apologies for the inconvenience.
Posted Mar 25, 2026 - 16:45 CET
This incident affects: Exact Multivers.