Exact Status Page

Exact Online - Not verified as Legal representative when completing Peppol registration (BE)

Incident Report for Exact System

Resolved

This issue has been resolved. You won't get an invalid error that you are not verified as the Legal representative of your company anymore when you want to complete the registration by signing via Itsme. If the match can't still be verified, the responsible team will contact you. Our apologies for the inconvenience.
Posted Aug 29, 2025 - 16:13 CEST

Monitoring

We have implemented a solution and we are monitoring the results. We will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Aug 27, 2025 - 13:53 CEST

Identified

You may get an error that you are not verified as the Legal representative of your company when you want to complete the Peppol registration by signing via Itsme. We have identified the issue and we are working on a solution. We will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Aug 08, 2025 - 11:20 CEST
This incident affected: Exact Online.