This issue has been resolved. Our apologies for the inconvenience.
Posted Feb 05, 2026 - 16:38 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2026 - 14:41 CET
Identified
It may be that your manual verification for your Peppol subscription takes longer than expected. The issue has been identified and a fix is being implemented. Our apologies for the inconvenience.