Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 28, 2026 - 22:00 CET
Scheduled
Auditplan will be undergoing scheduled maintenance on Wednesday, January 28, from 10:00 PM until 1:00 AM on Thursday, January 29. During this maintenance, Audit plans cannot be opened or created. We apologize for any inconvenience this may cause and appreciate your understanding.
Posted Jan 27, 2026 - 12:16 CET
This scheduled maintenance affected: Exact Online Jaarrekening.