This incident has been resolved, the portal can be accessed again. Our apologies for the inconvenience.
Posted Mar 14, 2025 - 11:30 CET
Investigating
You may get an error message stating 'Your connection is not private' while trying to access the collaboration portal from Exact Online Fiscal and Annual reporting. We are currently investigating the cause of this issue. You can expect daily status updates or as soon as new information is available. Our apologies for the inconvenience.
Posted Mar 14, 2025 - 09:52 CET
This incident affected: Exact Online Collaboration.