All Products - Support not reachable through phone (Global)
Incident Report for Exact System
Resolved
All phone lines are available once more. Our apologies for the inconvenience.
Posted May 14, 2024 - 09:34 CEST
Investigating
Currently we are facing technical issues with the Exact Support phone lines. As a result, you are not able to call Support at this moment. Please use our alternative support options to contact support on https://support.exact.com instead. Our apologies for the inconvenience.
Posted May 14, 2024 - 09:02 CEST
This incident affected: Customer Support Department.