This issue has been resolved and the screening can now be completed in full. If the white screen still appears, it may help to refresh the session by logging out and logging back in, and then trying again. Our apologies for the inconvenience.
Posted Sep 01, 2025 - 10:37 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 29, 2025 - 16:46 CEST
Investigating
When trying to confirm the company screening a 503 error or white screen is shown. We are working on a solution. Our apologies for the inconvenience.
Posted Aug 29, 2025 - 10:44 CEST
This incident affected: Exact Online and Exact Online Premium.