All products - Unable to use Exact PSD2 for Rabobank or Rabo BoekhoudKoppeling bank link to receive transactions or send payments (NL)

Incident Report for Exact System

Resolved

This issue has been resolved. You are able to use your Exact PSD2 for Rabobank or Rabo BoekhoudKoppeling bank link to receive transactions or send payments again. Our apologies for the inconvenience.
Posted May 14, 2025 - 11:07 CEST

Identified

Currently, it is not possible to use your Exact PSD2 for Rabobank or Rabo BoekhoudKoppeling bank link to receive transactions or send payments. Rabobank is working hard to solve the issue. We will update this page as soon as new information becomes available. Our apologies for the inconvenience.
Posted May 14, 2025 - 09:36 CEST
This incident affected: Bank links / PSD2.