This issue has been resolved. All bank statements are delivered. Our apologies for the inconvenience.
Posted Jun 18, 2025 - 15:25 CEST
Update
The daily statements of June 14th-16th are delivered by ABN AMRO and imported in Exact Online. Some statements which contain transactions of June 17th are still missing. ABN AMRO is working hard to deliver the missing statements as soon as possible.
Posted Jun 18, 2025 - 09:11 CEST
Identified
ABN AMRO has identified the issue and they are working on a fix.
Posted Jun 17, 2025 - 16:58 CEST
Investigating
It is possible that your bank statements have not been updated automatically since June 14th when using the ABN AMRO boekhoudkoppeling (1.0). Please note that not all bank links are affected and that the issue does not affect the Exact PSD2 link for ABN AMRO. ABN AMRO is working hard to resolve the issue. We will update this page once more information becomes available. Our apologies for the inconvenience.