This issue has been resolved. Our apologies for the inconvenience.
Posted Sep 10, 2026 - 13:19 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 10, 2026 - 13:00 CEST
Identified
As we are implementing a fix, Exact Online Premium is currently unavailable.
Posted Sep 10, 2026 - 12:54 CEST
Investigating
You may experience degraded performance or unexpected errors in Exact Online Premium. We are investigating the issue. As soon as more information becomes available we will update this page. Our apologies for the inconvenience.