Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 20, 2025 - 03:30 CEST
Scheduled
We will be undergoing maintenance for the Exact Proquro mail service on August 20th from 3.30AM - 4.30AM CEST. Due to this maintenance you will not be able to send or receive emails on mail.proquro.net. Our apologies for the inconvenience.
Posted Aug 15, 2025 - 10:57 CEST
This scheduled maintenance affected: Exact Proquro.