EOL - ING bank statements are delayed (NL)
Incident Report for Exact System
Resolved
All ING bank statements have been delivered. Our apologies for the inconvenience.
Posted Oct 28, 2023 - 15:43 CEST
Investigating
The ING bank statements are not delivered yet. We are working hard to solve this issue. When an update is available, we will inform you. Apologies for the inconvenience. (NL)
Posted Oct 28, 2023 - 12:05 CEST