Exact Status Page

Exact Online - Missing statements via Exact PSD2 link for KBC (BE)

Incident Report for Exact System

Resolved

The issue has been resolved by KBC. Affected statements have been imported with a delay. Our apologies for the inconvenience.
Posted Dec 09, 2025 - 17:04 CET

Investigating

You may experience missing bank statements via the Exact PSD2 link for KBC. KBC is currently investigating this issue. Our apologies for the inconvenience.
Posted Dec 03, 2025 - 09:19 CET
This incident affected: Bank links / PSD2.