Exact Online - No bank statements delivered during the weekend for the Exact PSD2 bank link for ABN AMRO(NL)

Incident Report for Exact System

Identified

We have identified the issue and we are working on a solution. We will update this page as soon as more information becomes available.
Posted Oct 29, 2025 - 11:39 CET

Investigating

You may experience that your bank statements of the weekend are missing when you use the Exact PSD2 bank link for ABN AMRO. This issue is not limited to the past weekend. We are investigating the issue and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Oct 27, 2025 - 13:18 CET
This incident affects: Exact Online and Exact Online Premium.