A fix has been implemented and we are monitoring the results.
Posted Sep 27, 2024 - 10:14 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 27, 2024 - 08:49 CEST
Investigating
You may experience that the transaction data from your ICS Mastercard credit cards has not been delivered to SRXP or has been partially delivered. We are investigating the cause of the issue. We will update this page as soon as new information becomes available. Our apologies for the inconvenience.