Exact Proquro - Invoices remain stuck in the Inbox.
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted Nov 22, 2024 - 16:23 CET
Investigating
It is possible that invoices remain stuck in the Inbox in the processing step. We are aware of this and are working on a solution. Our apologies for the inconvenience.
Posted Nov 22, 2024 - 10:32 CET
This incident affected: Exact Proquro.