Exact Status Page

Exact Online - White screen when logging in to Exact Online (BE)

Incident Report for Exact System

Resolved

This issue has been resolved. Our apologies for the inconvenience.
Posted Jun 10, 2026 - 20:06 CEST

Investigating

You may encounter a white screen or see a frozen loading screen when attempting to login to Exact Online Belgium or when you try to switch users. We are investigating this issue and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Jun 10, 2026 - 17:53 CEST
This incident affected: Exact Online.