Exact Status Page

Exact Venice - Error message during login (BE)

Incident Report for Exact System

Monitoring

We have implemented a complete fix and we are monitoring the results.
Posted Jun 01, 2026 - 11:56 CEST

Identified

We have identified the issue and access has been partially restored. We are seeing improvements in the availability of Exact Venice. Availability may vary within your organisation. We are continuing to work on a complete solution.
Posted Jun 01, 2026 - 10:54 CEST

Investigating

You may receive an error message while trying to login to Exact Venice. We are investigating this issue, and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Jun 01, 2026 - 09:20 CEST
This incident affects: Exact Venice.