Exact Status Page

KNAB statements not delivered (Exact Online, NL)

Incident Report for Exact System

Resolved

The KNAB statements are delivered. Our apologies for any inconvenience caused.
Posted Sep 02, 2022 - 16:41 CEST

Investigating

We are currently investigating this issue.
Posted Sep 02, 2022 - 08:10 CEST