This issue has been resolved. MyFirm users can be selected to approve payroll tax declarations for sending again. Our apologies for the inconvenience.
Posted Jul 01, 2026 - 13:49 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 30, 2026 - 08:28 CEST
Investigating
It is currently not possible to assign payroll tax declarations to MyFirm users to approve for sending. MyFirm users are therefore unable to approve payroll tax declarations. We are investigating this issue and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Jun 24, 2026 - 10:09 CEST
This incident affected: Exact Online and Exact Online Payroll & HR.