ING statements not processed yet (EOL - NL)

Incident Report for Exact System

Resolved

This incident has been resolved. Our apologies for any inconvenience caused.
Posted Sep 13, 2022 - 10:00 CEST

Investigating

The ING bank statements are not processed yet. We are working hard to solve this issue. Our apologies for any inconvenience caused.
Posted Sep 13, 2022 - 08:34 CEST