Exact Online Fiscal and Annual Reporting - There is a delay in our environment (NL)

Incident Report for Exact System

Resolved

The issue has been resolved. Our apologies for the inconvenience.
Posted Mar 18, 2025 - 09:15 CET

Update

The issue has been resolved. Our apologies for the inconvenience.
Posted Mar 18, 2025 - 09:15 CET

Investigating

There is a delay in our environment. You may experience errors or long waiting times. We are currently investigating the cause of this issue. You can expect daily status updates or as soon as new information is available. Our apologies for the inconvenience.
Posted Mar 18, 2025 - 09:01 CET
This incident affected: Exact Online Fiscaal and Exact Online Jaarrekening.