Status

Exact HR & Salarisgemak - Not possible to login (NL)

Incident Report for Exact System

Resolved

This issue has been resolved. Our apologies for the inconvenience.
Posted Jan 31, 2026 - 11:46 CET

Investigating

It is currently not possible to log in to Exact HR & Salarisgemak. We are investigating the issue. Our apologies for the inconvenience.
Posted Jan 31, 2026 - 11:16 CET
This incident affected: Exact HR & Salaris Gemak.