Exact Online Premium – Exact Online Premium is experiencing slowness (NL)
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted Apr 05, 2024 - 16:42 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 05, 2024 - 10:16 CEST
Investigating
You may experience long wait times and time-outs using Exact Online Premium. We are currently investigating the cause of this issue. You will receive status updates as soon as new information is available on this page. Our apologies for the inconvenience.
Posted Apr 05, 2024 - 09:41 CEST
This incident affected: Exact Online Premium.