Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 03, 2024 - 18:00 CEST
Scheduled
We will be undergoing maintenance between 18:00 -22:00 CET on 03-10-2024 on our Cloud Platform. During the maintenance we will update the Cloud Platform to the recent Service Pack for Exact Globe 424, Exact Globe+ 503 and Exact Synergy 502/503. During the maintenance session, you will not be able to use Exact Globe, Exact Globe+ and Exact Synergy Our apologies for the inconvenience.
Posted Oct 02, 2024 - 15:59 CEST
This scheduled maintenance affected: Exact Cloud Services.