Exact Online Premium - Not possible to log in (Global)

Incident Report for Exact System

Resolved

This issue has been resolved. Our apologies for the inconvenience.
Posted Mar 11, 2025 - 16:53 CET

Investigating

Currently it is not possible to log in to Exact Online. We are investigating the issue. We will update this page as soon as new information becomes available. Our apologies for the inconvenience caused.
Posted Mar 11, 2025 - 15:36 CET
This incident affected: Exact Online Premium.