Exact Online - Unable to finish PEPPOL registration (NL/BE)

Incident Report for Exact System

Resolved

This issue has been resolved. You are able to finish your PEPPOL registration when the company name and/or the bank account number have been already verified. Our apologies for the inconvenience.
Posted Mar 28, 2025 - 09:41 CET

Update

This issue has been identified and we are currently working on a fix.
Posted Feb 18, 2025 - 09:23 CET

Investigating

You may experience issues with finishing your PEPPOL registration while you may have already verified the company name and/or the bank account number. We are investigating this issue. This page will be updated as soon as more information is available. Our apologies for the inconvenience.
Posted Feb 14, 2025 - 11:45 CET
This incident affected: Exact Online.