This issue has been resolved. If this issue persists, it can be solved by stopping the Windows App using Task Manager. After, logging in will be succesful. Our apologies for the inconvenience.
Posted Jun 03, 2026 - 11:36 CEST
Investigating
You may experience being stuck in a loop when trying to login to Exact Multivers Online or in Boekhoud Gemak with a user not yet migrated to One Exact Identity. After receiving the pop-up titled "Laten we uw account veilig houden" the page does not load and you have to re-enter your credentials . We are investigating this issue, and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.
Posted Jun 01, 2026 - 11:53 CEST
This incident affected: Exact Boekhoud Gemak and Exact Multivers.