Exact Online - Performance issues Exact Online (NL)

Incident Report for Exact System

Resolved

The issue has been resolved. There are no more performance issues via different menupaths. Our apologies for the inconvenience.
Posted Apr 23, 2025 - 14:42 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2025 - 16:40 CEST

Investigating

You may experience performance issues via different menupaths. We are investigating this issue. This page will be updated as soon as more information is available. Our apologies for the inconvenience.
Posted Apr 22, 2025 - 13:03 CEST
This incident affected: Exact Online.