The issue has been resolved. All missing statements have been imported. Our apologies for the inconvenience.
Posted Nov 26, 2025 - 09:53 CET
Monitoring
We have implemented a fix and we are monitoring the results.
Posted Nov 25, 2025 - 19:50 CET
Identified
The issue has been identified and we are working on a solution.
Posted Nov 25, 2025 - 10:34 CET
Investigating
You may experience that there are no bank statements imported via your ING 1.0 bank link. We are investigating this issue and we will update this page as soon as more information becomes available. Our apologies for the inconvenience.