At the moment, all reported support cases relating to the Dimona declarations of 25 June have been identified and are being resubmitted in stages. Once these have been processed by the RSZ and Exact Horeko, you will be notified in your support case. If you have not submitted anything, please contact the RSZ to submit it manually. Our apologies for the inconvenience.
Posted Jul 16, 2026 - 15:01 CEST
Update
If you haven’t done so yet, please enter the hours for June 25 correctly under “Clocked Hours.” Once this has been done we ask that you provide us with this information through a support case. Based on that, we can ensure that the missing Dimona reports are properly submitted to the RSZ.
Posted Jul 10, 2026 - 13:58 CEST
Identified
You may experience that on June 25, some Dimona declarations were not successfully submitted to the RSZ. We have identified the issue and are working on a fix. We will update this page as soon as more information becomes available. Our apologies for the inconvenience.