Bank files Knab are delayed
Incident Report for Exact System
Resolved
This incident has been resolved.
Posted Jun 21, 2019 - 11:46 CEST
Investigating
We are currently investigating this issue.
Posted Jun 21, 2019 - 10:04 CEST
This incident affected: Netherlands (Boekhouden).