Exact Status Page

Exact Online - Not possible to start a support chat (Global)

Incident Report for Exact System

Resolved

This issue has been solved. The support chat is available again. Our apologies for the inconvenience.
Posted Apr 15, 2026 - 11:03 CEST

Investigating

Currently we are facing technical issues with the Exact Support page. As a result, you are not able to start a support chat at this moment. This page will be updated as soon as more information is available. Our apologies for the inconvenience.
Posted Apr 15, 2026 - 09:54 CEST
This incident affected: Customer Support Department.